This project is read-only.

The role 'administrators' was not found

Jun 16, 2011 at 10:14 AM


I installed dotnetage package manualy. First I've installed database. Second I've deployed dotnetage application to IIS7. The application is running good, but when I try to install some template I get error like: The role 'administrators' was not found.

Can anyone help with this issue?

Jul 14, 2011 at 12:53 AM

I have the same problem and stuck in the intallation page


Jul 19, 2011 at 10:05 PM

Did you guys found a solution to this issue ?

Jul 25, 2011 at 3:58 AM


Installation wizard

Choice your web template Choice your web template

The role 'administrators' was not found.    
This CMS Project is shit.So many bugs?
Jul 25, 2011 at 3:23 PM

I solve this problem by installing the run time version from the "Microsoft Web Platform Installer" and just point the version i downloaded here to that DB.

That worked quite well.. 

Jul 26, 2011 at 6:16 AM

Thanks for help!

Aug 5, 2011 at 4:22 PM

I had this problem too, found hout I misinterpreted the "Application name" in the installing wizard. 

Cause of that, In the aspnet_applications I had an application with name "Foo" , but in the web.config I had ApplicationName (for the membership providers) set up as "/" (usually,the default)

I changed the applicationname in the aspnet_applications table to "/" and it all worked fine..obviously the provider couldn't find any role for the / application before of that.